Resolved
The fix has improved the performance back to their normal levels.
Monitoring
A fix has been deployed, we are monitoring the performance.
Investigating
We are seeing a decrease in our database performance causing various actions in the app to hang. Our engineering team is investigating the root cause.