Cloudflare has confirmed that the incident has now been resolved, and we are seeing that change requests are working as expected.
Resolved
Cloudflare has confirmed that the incident has now been resolved, and we are seeing that change requests are working as expected.
Monitoring
We are still monitoring the current incident. Cloudflare has identified and is resolving the issue, and has updated its status page here.
Identified
We've identified an ongoing incident with Cloudflare, who have updated their status page here. This is impacting change requests, where creating new requests or merging existing ones is working intermittently.